SSL Error when ingesting data or running a backtest (_ssl.c:777)


#1

Hallo everybody,

I took a break from working with Catalyst for a while and tried out different stuff in a completly different environment. I also installed the new Windows update April 2018.

Now I am facing the problem that whenever I want to run a backtest or ingest some data I am running into the following error:

WARNING: CCXT: unable to fetch markets bitfinex: bitfinex https://api.bitfinex.com/v1/symbols_details GET HTTPSConnectionPool(host='api.bitfinex.com', port=443): Max retries exceeded with url: /v1/symbols_details (Caused by SSLError(SSLError(1, '[SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:777)'),))

I googled a bit and created the following python script that creates the same error.
import ccxt
bitfinex=ccxt.bitfinex()
orderbook1 = bitfinex.fetch_order_book('ETH/BTC')
print(orderbook1)

The script worked well on someone else’s computer.

I already uninstalled anaconda and set up a totally clean and fresh enviroment for Catalyst. Still the same problem.

Did anybody ever had to deal with this issue? Any ideas what could lead to the solution? Is it the Windows update?

Cheers
Jan


#2
  • Adding python.exe as exception to Windows Firewall didn’t work
  • Adding python.exe of the catalyst environment as exception to Windows Firewall didn’t work
  • Switching off Windows and Kasperky Firewall didn’t work
  • Adding ssl_verify: false to .condarc didn’t work
  • conda config --set ssl_verify false didn’t work
  • Installing Ubuntu 16.04 in VMware Workstation 12.5.7 on the same Windows machine and installing Catalyst didn’t work. Same error for both - ingesting data and the mini script - but this time with (_ssl.c:883)

#3

Hi, currently, Catalyst is experiencing issues with ingesting Bitfinex data you are welcome to follow this link or this issue to get updated when the problem is resolved.