Solved: Error code 1 installing pip when creating catalyst environment


#1

Hi there,

I tried to create a catalyst environment for the first time, getting the following error:
<<
Command “C:\Users\Ernst\Anaconda3\envs\catalyst\python.exe -u -c “import setupto ols, tokenize;file=‘C:\Users\Public\Documents\Wondershare\CreatorTemp\ pip-build-f08suqbw\bcolz\setup.py’;f=getattr(tokenize, ‘open’, open)(file) ;code=f.read().replace(’\r\n’, ‘\n’);f.close();exec(compile(code, file, ‘exe c’))” install --record C:\Users\Public\Documents\Wondershare\CreatorTemp\pip-7cc zgi7b-record\install-record.txt --single-version-externally-managed --compile” f ailed with error code 1 in C:\Users\Public\Documents\Wondershare\CreatorTemp\pip -build-f08suqbw\bcolz
.
CondaValueError: pip returned an error

I wonder what “wondershare” has to do with it, I use a wondershare pdf tool indeed, but cannot see any connection to catalyst…

Using win 8.1, having done all the installations reecommended here:

Using the environmet file from
https://raw.githubusercontent.com/enigmampc/catalyst/master/etc/python3.6-environment.yml

command issued in Anaconda Prompt:
conda env create -f g:/catalyst/conda/python3.6-environment.yml

win user not having administrator rights, should be?

Thanks for any help

P.S.There has been a wheel build error before obviously:
<<

  • Build Tools": http://landinghub.visualstudio.com/visual-cpp-build-tools


    Failed building wheel for statsmodels
    Running setup.py clean for statsmodels
    Running setup.py bdist_wheel for toolz … done
    Stored in directory: C:\Users\Ernst\AppData\Local\pip\Cache\wheels\f4\0c\f6\ce
    6b2d1aa459ee97cc3c0f82236302bd62d89c86c700219463
    Running setup.py bdist_wheel for wrapt … done
    Stored in directory: C:\Users\Ernst\AppData\Local\pip\Cache\wheels\48\5d\04\22
    361a593e70d23b1f7746d932802efe1f0e523376a74f321e
    Successfully built alembic attrdict empyrical idna-ssl intervaltree mako network
    x parsimonious python-editor redo requests-ftp rlp sqlalchemy toolz wrapt
    Failed to build bcolz bottleneck cyordereddict cytoolz enigma-catalyst lru-dict
    statsmodels
    Installing collected packages: pycares, aiodns, async-timeout, idna, idna-ssl, m

P.S. 2nd:
Auch mit adminrechten tritt der gleiche Fehler auf (remove environment -> fehlerfrei; create env.: gleicher fehler.
Same error with admin rights…


#2

Versuche es mit der Installation von:
Visual Studio Build Tools 2017


#3

Also gepromptet wird u.a.

failed building wheels for bcolz

error: Microsoft Visual C++ 14.0 is required. Get it with “Microsoft Visual
C++ Build Tools”: http://landinghub.visualstudio.com/visual-cpp-build-tools

Leider funktioniert der landinghub Link nicht mehr. Habe VS Build Tools 2017 installiert, ohne erkennbare Auswirkung leider. vielleicht die falsche Version? Im Wirrwarr der MS Versionen kenne ich sich mal einer aus…


#4

Muß wohl VS 2015 sein, also 2017er deinstalliert und Visual Studio Community 2015 with Update 3 installieren:
grafik


#5

SOLVED

Es lag tatsächlich an der fehlenden VS Build Komponente…

Sollte eigentlich beim Anaconda mit installiert worden sein, erinnere mich, das Häkchen war gesetzt…

Wie auch immer, es fluppt nun:sunglasses:

Reason was the missing VS Compiler, do not know why it was not installed with anaconda (option was set). Anyway, all working fine till now:grinning: