Error when installing


#1

Hi guys i’ve been trying for days intalling on ubuntu or win 10, on win 10 i could get more forward with the installation.
I was with a certifi conflict, but i’ve managed to erase the line from .yml and installed by my own.

Cannot uninstall ‘certifi’. It is a distutils installed project and thus we cannot accurately determine which files belong to it which would lead to only a partial uninstall.

now im with an issue that i can’t find a way to overcome
Command “python setup.py egg_info” failed with error code 1 in C:\Users\user\AppData\Local\Temp\pip-install-8a58j7bx\enigma-catalyst\

what do you guys recommend ?
thanks in advance


#2

Hi,

Have you installed the requirements needed for Linux and Windows prior to installing catalyst?

In Linux you should be able to install catalyst using both methods (conda and pip), with both Python version (2 and 3). I advise you tp go through the troubleshooting sections in our installation guide.

Unfortunately while the windows conda Python2.7 yml file works correctly, there is currently an issue with the windows conda Python3 yml file as discussed on github issue #407.
We are addressing this in our next release. In the meantime you can try to use the still work-in-progress updated yml file created for windows Python3 on our develop branch and let us know if you observe any issues.

If these issues are not resolved, please post your erros with a description of your environment and the exact steps you have followed.

Thanks,
Lena


#3

Lena, first of all, thank you for your kindness.
Im on win 10 python 3.6(or 3.7 if updated on my 1000 tries), how can i rollback everything ?(python and condas and pips ?) (i will write everything down this time)
I’ll try with 2.7 if it’s better
I will start from scratch today, again and with that .yml as well.

thank you, so much.:grinning::+1:


#5

tried one time with the .yml above, and it wasn’t working, but right after, i’ve put the command again, and installed correctly, now i can even see the version installed (something that i never saw)
thank you so much, now i’ll study the next steps
:grinning:


#6

@lena Hello :slight_smile:i’ve tried to install on another computer and i keep getting errors, where can i show you ? the forum says i’ve reached the limit, and pastebin too.
Thanks a lot @lena


#7

Hi @joao,

Have you gone over all the troubleshooting sections?
You can try to paste the tail of the errors you’ve received. An alternative is to use our Discord community, and head over the #catalyst_dev channel.

Lena


#8

Yes, i’ve tried

via pip

Found existing installation: certifi 2018.8.24
Cannot uninstall ‘certifi’. It is a distutils installed project and thus we cannot accurately determine which files belong to it which would lead to only a partial uninstall.

via pipeenv
Command “python setup.py egg_info” failed with error code 1 in c:\users\user\appdata\local\temp\pip-install-0tuleo\statsmodels\

Command “python setup.py egg_info” failed with error code 1 in c:\users\user\appdata\local\temp\pip-install-0ju1ei\statsmodels\

thanks :slight_smile:


#9

There is a thread discussing this issue: Fixed Cannot uninstall 'certifi'