Error during installation please help

#1

hello!
In every try to install catalyst throu anacond i get the same error
UPDATING build\lib.win-amd64-3.6\catalyst/_version.py
set build\lib.win-amd64-3.6\catalyst/_version.py to ‘0.5.21’
running build_ext
cythoning catalyst/assets/_assets.pyx to catalyst/assets_assets.c
c:\users\user\appdata\local\temp\pip-install-mnzbv_6b\enigma-catalyst.eggs\cython-0.29.6-py3.6-win-amd64.egg\Cython\Compiler\Main.py:367: FutureWarning: Cython directive ‘language_level’ not set, using 2 for now (Py2). This will change in a later release! File: C:\Users\User\AppData\Local\Temp\pip-install-mnzbv_6b\enigma-catalyst\catalyst\assets_assets.pyx
tree = Parsing.p_module(s, pxd, full_module_name)
building ‘catalyst.assets._assets’ extension
creating build\temp.win-amd64-3.6
creating build\temp.win-amd64-3.6\Release
creating build\temp.win-amd64-3.6\Release\catalyst
creating build\temp.win-amd64-3.6\Release\catalyst\assets
cl.exe /c /nologo /Ox /W3 /GL /DNDEBUG /MT -IC:\Users\User.conda\envs\catalyst\lib\site-packages\numpy\core\include -IC:\Users\User.conda\envs\catalyst\include -IC:\Users\User.conda\envs\catalyst\include “-IC:\Program Files (x86)\Windows Kits\10\include\10.0.17763.0\shared” “-IC:\Program Files (x86)\Windows Kits\10\include\10.0.17763.0\um” “-IC:\Program Files (x86)\Windows Kits\10\include\10.0.17763.0\winrt” “-IC:\Program Files (x86)\Windows Kits\10\include\10.0.17763.0\ucrt” “-IC:\Program Files (x86)\Windows Kits\NETFXSDK\4.6.1\include\um” /Tccatalyst/assets_assets.c /Fobuild\temp.win-amd64-3.6\Release\catalyst/assets_assets.obj
error: command ‘cl.exe’ failed: No such file or directory


Failed building wheel for enigma-catalyst
Running setup.py clean for enigma-catalyst
Building wheel for statsmodels (setup.py) … error
Complete output from command C:\Users\User.conda\en

0 Likes