Binance minute bar on btc_usdt Availability


#1

I’m trying to extract the btc_usdt minute bar data to the latest timestamp available on binance bundle.

according to https://enigma.co/catalyst/status/#Binance
Start Date Daily Data Up To Minute Data Up To
btc_usdt BTCUSDT 2017-08-18 2018-07-20 2018-07-21

if a run a back test starting from 2017-08-18 and run inside handle():

open = data.current(context.asset, ‘open’) # same for close high,low,etc…
i return Nan for all the values.

I even ran a back test on a shorter time frame starting from June 2018 but the result is still the same:
[Timestamp(‘2018-06-27 15:03:00+0000’, tz=‘UTC’), nan, nan, nan, nan, 0]

My Question is:
Up to which date is the minute bundle updated?
Few minutes earlier I finished to run
catalyst ingest-exchange -f minute -x binance

HEre’s the code which starts the backtest

start = datetime.datetime(2017, 8, 18, 0, 0, 0, 0, pytz.utc)
end = datetime.datetime(2018, 7, 20, 23, 59, 0, 0, pytz.utc)
results = run_algorithm(start=start, end=end,
capital_base=1, # amount of quote_currency
initialize=self.cat_initialize,
handle_data=self.cat_handle,
analyze=self.cat_analyze,
exchange_name=self.current_exchange.name,
data_frequency=data_frequency,
quote_currency=‘btc’,
live=False,
live_graph=False,
algo_namespace=‘test’)

Thanks in advance,
Luca


#2

Hi Luca,

Which dates are resulted with Nan values?
I suggest you to run catalyst ingest-exchange -x binance -f minute -i btc_usdt and try again.

The bundles are updated on catalyst servers every 24H so there is information up to the last 24H.
Each time you need to get the latest information, simply run the ingestion command again.


#3

Hi Lena,
all the dates up to July 1st are Nan:

    [Timestamp('2018-06-30 23:59:00+0000', tz='UTC'), nan, nan, nan, nan, 0]
    [Timestamp('2018-07-01 00:00:00+0000', tz='UTC'), 6391.08, 6395.0, 6395.0, 6389.99, 59.668005]

The first tick I get is from July 1st.

Even after running
ingest-exchange -x binance -f minute -i btc_usdt

the first minute tick i get is from july 1st ;(


#4

Hi Luca,

I wasn’t able to reproduce this.
Perhaps the first ingestion of the data was corrupted.
If you don’t have too much data ingested already, I would try to workaround this by clearing the exchange data using catalyst clean-exchange -x binance and re-ingesting from scratch the btc_usdt minute data.


#5

Thanks Lena it worked!
I did a quick test around January 1st and it showed the correct prices.

Is there a way to inspect the dataset/bundle through command line without running a backtesting?


#6

Unfortunately currently there is no such way.